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1 Introduction to ESA SNAP software and work with 
Sentinel-1 & Sentinel-2 satellite imagery 

1.1 ESA SNAP software 

ESA SNAP is as free software distributed under GNU license. Developed and supported by ESA, 
first of all aims to offer efficient, public tool for raster satellite data processing (optical and radar). 

1.1.1 Installation 

Installation files of ESA SNAP software are available to download on the 
http://step.esa.int/main/download/ website. User has a possibility to download one of three 
installation versions according to his needs (Fig. 1): 

 Sentinel-1, Sentinel-2 and Sentinel-3 toolboxes, 

 SMOS (Soil Moisture and Ocean Salinity) data toolbox, 

 Sentinel-1, Sentinel-2 and Sentinel-3, SMOS data and PROBA-V toolboxes – all accessible 
tools. 

 
Fig. 1. Available installation versions of ESA SNAP Software (source: step.esa.int) 

Work with satellite imagery of Sentinels family requires downloading first or third version. To 
download the installation file, please point Download choosing software version which also fits to 
users operating system (Windows 32- or 64-bit, Mac OS X, Unix 64-bit) and save it in a known 
directory. 

To install ESA SNAP software please double point the file.  Then proceed through the entire 
installation process. 

1.1.2 Application launch and interface overview 

ESA SNAP software can be launched by shortcut  on the desktop (created during the installation) 
or by Start Menu → Search → ESA SNAP Desktop. 

ESA SNAP software main window can be divided into several parts (Fig. 2): 

a) main toolbar – grouped in several categories tools for application configuration and read, 
write and process data, 

b) shortcuts toolbar – direct links to some functions of the software, 

c) navigation and data display panel – allows for easy navigation through read data, changing 
its visualization, saving after edition and calling some functions, 

http://step.esa.int/main/download/
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d) product library and layer manager panel – expandable windows allowing for managing 
large data sets and changing the way of current map window presentation (vector data style 
and transparency, layers order etc.) 

e) map window – allows for a visualisation of possessed data. 

 
Fig. 2. Main window of the ESA SNAP software 

It is only a default interface of application window, which can be configured during user needs and 
preferences to create user-friendly workspace for efficient work. 

1.1.3 Overview of software configuration capabilities 

Configuration options of ESA SNAP allows to fit the software interface to user needs, optimal 
allocation of hardware resources, defining the default way to display data and several other 
capabilities. Making changes in the interface is available in View panel from main toolbar (Fig. 3), 
and the other configuration tools are collected in Tools → Options window (Fig. 4).  

 
Fig. 3. ESA SNAP interface configuration menu  
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Fig. 4. ESA SNAP settings window 

  



 

8 

 

ESA SNAP Workbook created by 

1.2   Search, browse and download the Sentinel-1 & Sentinel-2 
data 

SciHub is a website providing access to Sentinel-1, Sentinel-2 and Sentinel-3 data. The website is 
available at https://scihub.copernicus.eu/. Open Access Hub is a map browser for download data 
of all the Sentinel missions working in operational mode through graphical user interface. For 
using the SciHub website it is necessary to own the user account. SciHub allows to search data by 
area, sensing time, ingestion time, sensor type, product type, three features typical for Sentinel-1 
mission: polarisation, sensor mode, orbit number and one feature typical for Sentinel-2 data -  the 
cloud cover.  

The content of map browser contains the following elements (Fig. 5): 

a) sign up and login buttons, 

b) tool for change the map backgruoud, 

c) tools for navigation and defining the area of interest, 

d) expandable search toolbar. 

 
Fig. 5. Open Access Hub window of SciHub website 

Exercise 1 Search and download Sentinel-1 data through SciHub website 

 Step 1. Open the web browser, type in address bar:  https://scihub.copernicus.eu/, confirm 

[Enter], and go to Open Hub  access point.  

 Step 2. Log in  typing login and password provided by trainer.  

 Step 3. Set navigation tool , slide view to your area of interest and choose rectangle 

 or polygon  area of interest drawing tool. 

 Step 4. Expand the list of advanced search options . 

 Step 5. Set the Sensing period as 1.09.2017-31.09.2017 r., mark Mission:Sentinel-1 

checkbox, choose Product Type: SLC and apply a search . 

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
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All images of the given parameters, whose range crosses the given area of interest, have been 
shown in the map window and listed on the results list on the left (Fig. 6).  

After point some image it is possible to move and zoom map range to this image, view its metadata 
and download the image to hard drive. 

 
Fig. 6. The effect of searching in Open Hub access point 

  



 

10 

 

ESA SNAP Workbook created by 

2 General raster tools 

2.1 Read, view and save the data 

It is advised to extract the downloaded file – it is necessary for working with Sentinel-2 data. 
According to system limitation of file path length, files should be placed so high in the hierarchy of 
directories as possible before extraction. To load data to workspace data can be opened (exercises 2 
and 3) or imported (exercise 4). Data import tool allows to work with many supported sensors and 
data formats (Fig. 7). 

 
Fig. 7. Optical sensors supported by ESA SNAP software 

Exercise 2 Sentinel-1 data reading in ESA SNAP software 

 Step 1. Launch the file adding window by select from the main toolbar File → Open Product 

or icon  from the shortcuts toolbar. 

 Step 2. In the opened add file window select Sentinel-1 Products from the Files of type 
drop-down list. 

 Step 3. Find Sentinel-1 image in the \\ESA_SNAP_workshops\source_data directory, 
open the main catalogue of the image, point manifest.safe file which allows for correct 
opening Sentinel-1 data and click Open (Fig. 8). Image will be added to application 
workspace and placed in Product Explorer tab. 
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Fig. 8. Sentinel-1image open in ESA SNAP Software 

Exercise 3 Sentinel-2 data reading in ESA SNAP software 

 Step 1. Launch the file adding window by select from the main toolbar File → Open Product 

or icon  from the shortcuts toolbar. 

 Step 2. In the opened add file window select Sentinel-2 Products from the Files of type 
drop-down list. 

 Step 3. Find Sentinel-2 image in the \\ESA_SNAP_workshops\source_data directory, 
open the main catalogue of the image, point MTD_MSIL1C.xml which allows for correct 
opening Sentinel-2 data and click Open (Fig. 9). Image will be added to application 
workspace and placed in Product Explorer tab. 

 
Fig. 9. Sentinel-2 image open in ESA SNAP Software 

Exercise 4 Data import in ESA SNAP software 

 Step 1. Launch the data import window by select from the main toolbar File → Import → 
Optical Sensors → Sentinel-2 →  S2-MSI. 

 Step 2. Find Sentinel-2 image in the \\ESA_SNAP_workshops\source_data directory, 
open the main catalogue of the image, point MTD_MSIL1C.xml file, used for Sentinel-2 
data import and point Import Product (Fig. 10). Image will be added to workspace and 
placed in Product Explorer tab. 



 

12 

 

ESA SNAP Workbook created by 

 
Fig. 10. Sentinel-2 image import in ESA SNAP Software 

Add or import data does not display the raster data in map window – it should be done by using a 
separate tool. ESA SNAP software allows to overview data from one or more sources in various 
configurations. 

Exercise 5 Raster spatial data display in ESA SNAP software 

 Step 1. Add the Sentinel-2 image from \\ESA_SNAP_workshops\source_data directory to 
the application workspace (you can also use the image added in previous exercise). 

 Step 2. Run the open map window tool from the main toolbar by Window → Open RGB 
Image Window or by point with right mouse button the added file in Product Explorer tab 
and selection Open RGB Image Window from the list. 

 Step 3. In the open map window tool set Profile as Sentinel 2 MSI Natural Colors (Fig. 11), 
which is responsible for standard RGB composition of the image bands by assign 
corresponding spectral bands to red, blue and green colour of the composition. Confirm 
with OK. 

 
Fig. 11. Open map window tool 

 Step 4. Repeat the operation of map window add, this time setting Profile as Sentinel 2 MSI 
False-color Infrared.  
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Fig. 12. ESA SNAP workspace with the RGB composition of Sentinel-2 image 

 Step 5. Repeat the operation of map window adding, this time setting Profile as Sentinel 2 
MSI Atmospheric penetration. 

 Step 6. Open the map window adding tool once again. Besides predefined profiles there is 
also possibility of user composition creation. Create some composition by setting as Red, 
Green and Blue any band of <B2, B3, B4, B8 – 10 m spatial resolutnion>, <B5, B6, B7, B8a, 
B11, B12 – 20 m spatial resolutnion> lub <B1, B9, B10 – 60 m spatial resolutnion> group 
(ESA SNAP demands RGB compositions be created from the bands with the same spatial 
resolution). 

 
Fig. 13. Creation of sample user RGB composition of Sentinel-2 image 

 Step 7. Active function  allows for slide view (with the left mouse button pressed) and 
change the scale of the displayed image (scroll wheel). Test the various capabilities of map 

windows arrangement selecting one by one icons  from shortcuts toolbar (Fig. 15). 
Activation the Synchronises views across multiple image windows function in the 
Navigation tab (Fig. 14) allows to perform these operations simultaneously for all images. 
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Fig. 14. Placement of the synchronization views function 

 
Fig. 15. ESA SNAP workspace with various RGB compositions of one image 

 Step 8.  Go from the Navigation to Colour Manipulation tab. Inside this tab is placed the 
histogram of the image, under witch are placed sliders for change the image presentation in 
map window – separately for bands Red, Green and Blue (Fig. 16). Try to change any of the 
image colorization watching at the same time how it is changing RGB visualizations. 
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Fig. 16. Red band of the image histogram in Colour Manipulation tab 

Exercise 6 Metadata 

Metadata is the necessary information about the data included in spatial data set. Its structure and 
content is usually defined in regulations e.g. INSPIRE Directive of the European Union. Metadata 
for satellite data includes, among other things, information about coordinate reference system, 
sensing time, spatial resolution and processing level. Without this information work with satellite 
data could be hard or even unavailable. 

 Step 1. Add the Sentinel-2 image from \\ESA_SNAP_workshops\source_data directory to 
the workspace (or use the image added in previous exercise). 

 Step 2. Explore the image in Product Explorer tab. Find the Metadata → Granules files and 
open metadata tab Level-1C_Tile_38TNM by double click. (Fig. 17). 

 
Fig. 17. Sentinel-2 image metadata exploration in ESA SNAP software 

 Step 3. View the content of the sample metadata tab. Try to find at least information about 
coordinate reference system of the image. (Fig. 18). 
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Fig. 18. Metadata presentation ESA SNAP software 

Exercise 7 Data save 

For data save it is necessary to make some change in dataset. Because of that all the ways to save 
the data will be presented in following exercises. Data save in ESA SNAP software is available by:  

 File → Save  (Fig. 19) option,  

 definition of directiory, name and format of the target data during set the process 
parameters → Exercise 8, 

 saving the copy of the data with made changes (File → Save As) → Exercise 10, 

 change data format (File → Export → …)→ Exercise 12. 

 
Fig. 19. Placement of File → Save option of ESA SNAP software 

  



                                              

 

 

 

 

17 

 

ESA SNAP Workbook created by 
by: 

2.2 Change the spatial resolution of image (Resampling) 

Resampling is the function which changes the size of image pixel to demand size. It allows to 
present and process data with different spatial resolution (e.g. from different sources)  in a uniform 
way. In case of work with Sentinel family satellite data it matters mainly for optical data, which are 
provided with three different pixel sizes – 10, 20 and 60 meters. Additionally, ESA SNAP software 
requires the same spatial resolution of every band in source image in most of the functions. 

Exercise 8 The spatial resolution change of Sentinel-2 image 

 Step 1.  Add the Sentinel-2 image from \\ESA_SNAP_workshops\source_data directory to 
the workspace. 

 Step 2. Run the resampling window by Raster → Geometric Operations → Resampling. 

 Step 3. In I/O Parameters tab in Source Product section choose the name of the added 
image from the drop-down list (Fig. 20). 

 
Fig. 20.  The source and target data definition of the resampling operation 

 Step 4. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_8\dest and the name of the resampled file. By default 
it is  name of the source file with resampled suffix. Mark Open in SNAP checkbox to load 
new created data in Product Explorer tab 

 Step 5. In Resampling Parameters tab sign By reference band from source product option 
and set band B2, B3, B4 or B8 (Fig. 21) – each of them has spatial resolution of 10 meters – 
the rest of bands will be resampled to this size in resampling process (Fig. 22). Leave the 
other settings as default and run the resampling with  button.  
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Fig. 21. The resampling parameters settings 

 Step 6. Create map windows of B1 band before and after resampling operation and set the 
simultaneous view of both windows. Zoom to the area of large changes in brightness as far 
to see single pixels (Fig. 22).  

 
Fig. 22. The result of resamplig operation in Sentinel-2 image 

 

Note that despite changing the size of single element of the image, general information provided 

by B1 spectral band did not change. 
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2.3 Change the coordinate reference system of the image 
(Reprojection) 

Every dataset exists in some coordinates reference system. Change the reference system is 
sometimes unnecessary, especially in work with data from various sources. Sentinel-2 data are 
delivered in UTM coordinate system. 

Exercise 9 Change the coordinate reference system of Sentinel-2 image 

 Step 1. Add the Sentinel 2 data from \\ESA_SNAP_workshops\exercise_9\src directory 
(or use the target file from exercise 8). 

 Step 2. Run the reprojection window by Raster → Geometric Operations → Reprojection 
(Fig. 23). 

 Step 3. In I/O Parameters tab in Source Product section choose the name of the added 
image from the drop-down list. 

 Step 4. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_9\dest and the name of the reprojected file. By default 
it is  name of the source file with reprojected suffix. Mark Open in SNAP checkbox to load 
new created data in Product Explorer tab. 

 
Fig. 23. The source and target data definition of the reprojection operation 

 Step 5. In Reprojection Parameters tab choose the Predefined CRS option, and run the 

coordinate reference system selection window by . In new opened window type 4326 
– EPSG code of WGS84 reference system, point it on the list and confirm OK. (Fig. 24).  



 

20 

 

ESA SNAP Workbook created by 

 
Fig. 24. Selection of the predefined coordinate system to reprojection 

 Step 6. Leave the rest of the settings as default and run the reprojection with  button. 

 
Fig. 25. The reprojection parameters settings 

 
  

EPSG is common, universal way for coordinate reference systems encoding. Every offical and 

national coordinate system should have its own EPSG code predefied in any GIS . 
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2.4 Dataset clipping 

Data from the Sentinel mission covers large area (10 000 km2 in case of optical imagery, about 
38 000 km2 in case of radar data) what makes it large in size and has negative impact on the 
processing time. For this reason ESA SNAP software offers an opportunity of limiting the spatial 
range of the data or choosing only that bands which are necessary for processing. 

Exercise 10 Spatial limitation of the Sentinel-1 dataset 

 Step 1. Add the Sentinel 2 data from \\ESA_SNAP_workshops\exercise_10\src directory. 

 Step 2. Select the added file from the list in the Product Explorer tab and run the subset 
window by Raster → Subset. 

 Step 3. In Spatial Subset tab go to the Geo Coordinates section and type the range of subset 
data (Fig. 26), and confirm OK. 

 
Fig. 26. Sentinel-1 data subset parameters 

 Step 4. Create map windows with RGB composition of source and target image and set the 
simultaneous view of both windows. Slide and zoom the view to the range of the target 
image (Fig. 27).  
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Fig. 27. The result of Sentinel-1 data subsetting 

 

 Step 5. The new data was created and added in Product Explorer tab, but the files was not 
stored on the hard drive. To save created dataset, select it on the list in Product Explorer 
and set File → Save Product As… or point dataset with right mouse button and choose Save 
Product As… from the list to open the data saving window (Fig. 28).  

 
Fig. 28. Placement of Save as… option 

 Step 6. In new opened window open navigation panel Save in:, select hard drive Local Disk 
(C:) and go to the \\ESA_SNAP_workshops\exercise_10\dest (Fig. 29).  

Note that despite difference in colorization of the images (which is tailored only to the change of 

the histogram statistics) in the common part the images provide the same information. 
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Fig. 29. Data saving window of ESA SNAP software. 

 Step 7. Leave the new file name (File Name) as default and save the image with  
button. 
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2.5 Area of interest clipping 

Limiting the source dataset with rectangular bounding box is not always satisfied to reach 
appropriate target data. Sometimes clipping source data to irregular shape of  area of interest (AOI) 
is also needed. In this case Land/Sea Mask tool of ESA snap is very useful. To perform the 
operation, the vector layer which defines border of clipping is necessary.  

Exercise 11 Clipping the Sentinel-1 image to the area of interest 

 Step 1. Add the Sentinel 2 data from \\ESA_SNAP_workshops\exercise_11\src directory, 
( or use the target file from exercise 10). 

 Step 2. Select the added file from the list in the Product Explorer tab and run vector file 
import window by Vector → Import → ESRI Shapefile (Fig. 30). 

 
Fig. 30. Placement of ESRI shapefile import tool 

 Step 3. Find vector layer AOI.shp in \\ESA_SNAP_workshops\exercise_11\src directory 
and add to previously selected raster file using Open button. 

 Step 4. Create map window with data visualization and look how vector data was shown on 
the satellite image. 

 Step 5. Run the window of area of interest clipping tool by Raster → Masks → Land/Sea 
Mask (Fig. 31). 

 Step 6. In I/O Parameters tab in Source Product section choose the name of the added 
image from the drop-down list. 

 Step 7. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_11\dest and the name of the masked file. By default it 
is the name of the source file with msk suffix. Mark Open in SNAP checkbox to load new 
created data in Product Explorer tab. 
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Fig. 31. The source and target data definition of the AOI clipping operation 

 Step 8. In the Processing Parameters tab mark the option Use Vector as Mask and from the 
drop-down list choose the layer added in Step 3. vector layer. Leave the other settings as 

default and run the resampling with  button.  

 
Fig. 32. AOI clipping parameters settings 
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 Step 9. Create the map windows with RGB composition of source image and image after 
AOI clipping, and set the simultaneous view of both windows (Fig. 33).  In the panel Layer 
Manager (on the right side of application window) unmark visibility of vector layer AOI. 

 
Fig. 33. The result of the area of interest clipping 

 

  

Note that the borders of clipped area are exactly the same as the range of the vector layer. 
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2.6 Band calculator 

Every raster image is in fact the table of the values (matrix) which makes performing arithmetic 
and logical operations on images possible, which allows to extract needed information from the 
satellite data. 

Exercise 12 Arithmetic operations on the Sentinel-1image bands 

 Step 1. Add the Sentinel 2 data from \\ESA_SNAP_workshops\exercise_12\src, directory 
(or use the target file from exercise 11). 

 Step 2. Run the band calculator window by Raster → Band Maths. 

 Step 3. Set image on which the calculations will be performed as the layer added in Step 1., 
name the new layer as intensity_div, unmark the Virtual option and run the expression 
creator with Edit Expression button (Fig. 35). 

 
Fig. 34. Edit expression window of band calculator of ESA SNAP software 

 Step 4. In new opened window type Intensity_VV/Intensity_VH – the operation of dividing 
pixel values of backscatter intensity in VV polarisation by corresponding values of 
backscatter intensity in VH polarisation. If the control of typed expression does not return 
any errors („Ok, no errors” statement), confirm the expression with OK button and run the 
calculation with OK button in the Band Maths window. 

 
Fig. 35. The band calculator parameters definition 

 Step 5. The new layer was calculated and automatically opened in map window. Close this 
window and open map window with RGB composition of the source raster layer. 
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 Fig. 36. Change of the default RGB composition band to the band from the exercise 

 Step 6. Open new map window, in which default Blue band will be changed to intensity_div 
layer created during the exercise. Open this two map windows simultaneously (Fig. 37). 

 
Fig. 37. Comparison of default (bottom) RGB composition of the image with composition 

with the layer created during exercise (upper)  

 
 

 Step 7. Image with new calculated band could be export in that form for allowing to RGB 
visualisation of that composition in any GIS software without doing on-the-fly calculation. 
Select image with three bands in Panel Explorer tab and choose File → Export → 
GeoTIFF/BigTIFF. 

Note that Blue band of the default composition is a realization of the expression from the 

previous step. 

Note that both visualisations present exactly the same information. 
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 Step 8. In new opened window open navigation panel Save in:, select hard drive Local Disk 
(C:) and go to the \\ESA_SNAP_workshops\exercise_12\dest.  

 Krok 9. Leave the new file name as default and export the image with  button.  

  

GeoTIFF is a universal graphic format supported by the most of the software dedicated to 

spatial information processing which allows also to save the georeference of the data. 
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3 Optical images processing tools 

3.1 Spectral indices 

The spectral indices calculations allows to extract or underline on the optical image information 
about condition of vegetation, presence of the water and other features demand by user. The 
Sentinel-2 images, because of the wide range of spectral bands are very good source for that type of 
processing. 

Exercise 13  Spectral indices calculations on the Sentinel-2 image 

 Step 1. Add the Sentinel 2 data from \\ESA_SNAP_workshops\exercise_13\src 
directory,( or use the target file from exercise 9). 

 Step 2. Run the window of NDVI calculation by Optical → Thematic Land Processing → 
NDVI Processor (Fig. 38). 

 Step 3. In I/O Parameters tab in Source Product section choose the name of the added 
image from the drop-down list, on which NDVI will be calculated. 

 
Fig. 38. The source and target data definition for the NDVI calculation 

 Step 4. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_13\dest and the name of created file. By default it is the 
name of the source file with ndvi suffix. Mark Open in SNAP checkbox to load new created 
data in Product Explorer tab. 

 Step 5. In Processing Parameters tab set Red source band as B4 and NIR source band as 

B8, and run the process with  button (Fig. 39). 

 
Fig. 39. The NDVI calculation parameters settings 
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 Step 6. Create map windows of RGB composition of the source image and NDVI image and 
set the simultaneous view of both windows. Compare the land cover in bright and dark 
areas. (Fig. 40). 

 
Fig. 40. Comparison of calculated NDVI and RGB composition of Sentinel-2  

 

  

Note that areas covered by green vegetation (forest, grasslands, crops) reach high (bright) values 

of NDVI. General range of the NDVI values is <-1 ; 1>. 
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3.2 The comparison of Sentinel-2 images with the high 
resolution images  

The Sentinel-2 imagery offers the best spatial resolution from all the free of charge optical data, but 
they do not exhaust the current possibilities of satellite imaging technology. 10 meters of size pixel 
is enough to create exact processing and value added data for the agricultural and less urbanized 
areas. More exact, commercial satellite data shows their advantages mainly in the cities, where 
spatial resolution in meters is not enough for precise analysis. 

Exercise 14 Comparison of Sentinel-2 and VHR Pleiades data. 

 Step 1. Add the Sentinel 2 data from \\ESA_SNAP_workshops\exercise_14\src directory. 

 Step 2. Add to the workspace also the VHR Pleiades image yerevan_pleiades.tif from the 
same directory. 

 Step 3.Create map windows with RGB composition of both images 

o Sentinel 2: Red – B4, Green – B3, Blue – B2, 

o Pleiades: Red – 1, Green – 2, Blue - 3,  

 and set simultaneous view of both windows. Zoom to the area of the city of Yerevan to be 
able to distinguish individual building. Compare the quality of the images. 

 
Fig. 41. Comparison of the Sentinel-2 image (10 m spatial resolution, upper) with Pleiades 

VHR image (0,5m spatial resolution, bottom), Yerevan, Armenia 
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4 Radar data processing tools 

4.1 Calibration 

Radar image calibration aims to associate the pixel value of the scene directly with the microwaves 
reflection from the surface of the image. In fact, non-calibrated image allows to performing the 
qualitative analysis, but the analysis with quantitative methods are possible only after calibration. 

Exercise 15 Calibration of Sentinel-1 image 

 Step 1. Add to the ESA SNAP workspace Sentinel-1 source file from the 
\\ESA_SNAP_workshops\source_data directory. 

 Step 2. Run the calibration tool window by Radar → Radiometric → Calibrate (Fig. 42).  

 Krok 3. In I/O Parameters tab in Source Product section set the added file from the drop-
down list. 

 
Fig. 42. The source and target data definition for the calibration process of Sentinel-1 image 

 In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_15\dest and the name of the calibrated file. By default 
it is the name of the source file with Cal suffix. Mark Open in SNAP checkbox to load new 
created data in Product Explorer tab. 

 Step 5. In Processing Parameters tab mark Save as complex output checkbox and both 
polarisations (left mouse button with pressed [Ctrl] button) and run the calibration process 

with  button  (Fig. 43).  
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Fig. 43. The calibration process parameters settings 
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4.2 Debursting 

Sentinel-1 data for single image are collecting with three swaths, which needs to be joined for the 
whole scene processing. This operation is called debursting. 

Exercise 16 The Sentinel-1 image debursting operation 

 Step 1. Add to the ESA SNAP workspace source file from the 
\\ESA_SNAP_workshops\exercise_15\src directory (or use the target file from exercise 
15). 

 Step 2. Run the debursting tool window by Radar → Sentinel-1 TOPS →Sentinel-1 TOPS 
Deburst (Fig. 44). 

 Step 3. In I/O Parameters tab in Source Product section set the added file from the drop-
down list. 

 
Fig. 44. The source and target data definition for the debursting process of Sentinel-1 image 

 Step 4. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_16\dest and the name of the debursted file. By default 
it is the name of the source file with deb suffix. Mark Open in SNAP checkbox to load new 
created data in Product Explorer tab. 

 Step 5. In Processing Parameters mark both polarisations, which will qualify them to the 

process and run the debursting process with  button  (Fig. 45). 
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Fig. 45. The debursting process parameters settings 
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4.3 Speckle filtering 

Looking at the raw radar image it is simply to assume that all of it is cover by a „fog”, which 
disturbs the perception of the information from the image. This noise is called „speckle”, which is 
available to delete in speckle filtration process.  

Exercise 17 Speckle filtering of Sentinel-1 image 

 Step 1. Add to the ESA SNAP workspace source file from the 
\\ESA_SNAP_workshops\exercise_17\src directory (or use the target file from exercise 
16). 

 Step 2. Run the speckle filtering tool window by Radar → Speckle Filtering →Single 
Product Speckle Filter (Fig. 46). 

 Step 3. In I/O Parameters tab in Source Product section set the added file from the drop-
down list. 

 
Fig. 46 The source and target data definition for the despeckle process of Sentinel-1 image 

 Step 4. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_17\dest o and the name of the filtered file. By default it 
is the name of the source file with Spk suffix. Sign Open in SNAP checkbox. Mark Open in 
SNAP checkbox to load new created data in Product Explorer tab. 

 Step 5. In Processing Parameters tab set Filter as Refined Lee and run the despeckle 
process with  button (Fig. 47). 
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Fig. 47. The despeckle process parameters settings 

 Step 6. Create map windows with RGB composition of the image before and after speckle 
filtering and set simultaneous view of both windows. Compare how the perception of the 
image increased thanks to despeckle process (Fig. 48). 

 
Fig. 48. Comparison of image before (upper) and after (bottom) despeckle operation 
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4.4 Terrain Correction 

The arrangement of Sentinel-1 image directly read from the source files reflects the direction of 
satellite flight over the collecting terrain and has only approximate georefence. For this reason to 
effective work with radar data performing the terrain correction is necessary 

Exercise 18 Terrain Correction of Sentinel-1 image 

 Step 1. Add to the ESA SNAP workspace source file from the 
\\ESA_SNAP_workshops\exercise_18\src directory (or use the target file from exercise 
17). 

 Step 2. Run the terrain correction tool window by Radar → Geometric →Terrain 
Correction → Range-Doppler Terrain Correction (Fig. 49). 

 Step 3. In I/O Parameters tab in Source Product section set the added file from the drop-
down list. 

 
Fig. 49. The source and target data definition for the terrain correction process of Sentinel-1 

data 

 Step 4. In Target Product section set the target directory as 
\\ESA_SNAP_workshops\exercise_18\dest and the name of the file after terrain 
correction. By default it is the name of the source file with TC suffix Mark Open in SNAP 
checkbox to load new created data in Product Explorer tab. 

 Step 5. In Processing Parameters tab set the starget piksel size (Pixel Spacing) as 10 meters 

and run the terrain correction process with  button (Fig. 50). 
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Fig. 50. Terrain correction parameters settings 

 Step 6. Create map windows with RGB composition of the image before and after terrain 
correction. Unmark the simultaneous view (in Navigation tab) because the images operate 
now in different coordinates systems (Fig. 51). 

 
Fig. 51. Comparison of Sentinel-1 image before (upper) and after (bottom) terrain correction 
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5 Processing paths creation and processing automation  

During the performing exercise 1-17 it can be noted that some processes are connecting into series, 
when the target image of one process become the source of the next one. Thanks to the 
GraphBuilder tool there is a possibility of automatic transistion through several processes and 
saved only the target data from the last of them. 

Exercise 19 Automation of optical images processing 

 Step 1. Run the GraphBuilder tool by Tools → GraphBuilder or by the  icon (Fig. 52). 

 Step 2. Load with  button prepared file Sentinel-2_graph.xml with processing graph 
from \\ESA_SNAP_workshops\exercise_19\src directory. 

 
Fig. 52. GraphBuilder tool window 

 Step 3. Validate the parameters entered into graph (and it is needed – correct them) 
starting with source data through values in particular processes, to directory and name of 
target files. Especially: 

o Read block: Sentinel-2 image from \\ESA_SNAP_workshops\source_data 
directory; 

o Resample block: By pixel resolution (in m) option with value 10; 

o Reproject block: Predefidned CRS option with coordinate system WGS84 set; 

o Import-Vector block: AOI.shp file from \\ESA_SNAP_workshops\exercise_18\src 
directory, unmarked Separate shapes checkbox; 

o Land-Sea-Mask block: Use Vector as Mask option with selected AOI layer; 
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o Subset block: Geographic Coordinates option, after zoom to image range (red frame) 
on the map, yellow area of clipping terrain should be placed inside image range. 
Navigation: right mouse button – sliding, scroll wheel – zoom; 

o Write block: the name of read file from Read block, marked save into 
\\ESA_SNAP_workshops\exercise_18\dest directiory and Open in Snap option. 

 Step 4. When all the parameters were entered correctly and GraphBuilder does not return 

any errors, run the process path with  button. 

 Step 5. When the processing is done, open the map window with RGB composition of target 
image. It was in sequence: resampled, reprojected, subset to close range and to the specific 
irregular area of interest (Fig. 53).  

 
Fig. 53. The effect of performing the series of operations on Sentinel-2 image by processing 
path collected in graph 
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Exercise 20 Automation of optical images processing, graph building 

 Step 1. Run the GraphBuilder tool by Tools → GraphBuilder or  icon. 

 Step 2. Clicking right mouse button in graphic window of GraphBuilder add calibration 
block by Add → Radar → Radiometric → Calibration (Fig. 54). 

 
Fig. 54. Adding new block to ESA SNAP Graph Builder 

 Step 3. Clicking right mouse button in graphic window of GraphBuilder add debursting 
block by Add → Radar → Sentinel-1 TOPS → TOPSAR Deburst; 

 Step 4. Clicking right mouse button in graphic window of GraphBuilder add despeckle 
block by Add → Radar → Speckle Filtering → Speckle-Filter; 

 Step 5. Clicking right mouse button in graphic window of GraphBuilder add terrain 
correction block by Add → Radar → Geometric-Terrain-Correction → Terrain-Correction; 
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Fig. 55. Graph Builder tool window with added blocks creation for process path creation 

 Step 6. Place (by drag&drop) added block into a path Read → Calibration → TOPSAR 
Deburst → Terrain-Correction → Speckle-Filter → Write i połącz je ze sobą (Fig. 56). 

 
Fig. 56. Connection the graph blocks into a processing path 



                                              

 

 

 

 

45 

 

ESA SNAP Workbook created by 
by: 

 Step 7. Passing one by one through every block add Sentinel-1 source file from 
\\ESA_SNAP_workshops\source_data directory, set parameters of subsequent operations 
analogous to exercises 15-18 and define target directory as 
\\ESA_SNAP_workshops\exercise_20\dest. 

 
Fig. 57. Ready graph with created processing path 

 Step 8. Save graph as Sentinel-1_graph.xml file in 
\\ESA_SNAP_workshops\exercise_20\dest directory and run the processing path with  

button . 

 
Figure 58. The effect of performing the series of operations on Sentinel-1 image by 
processing path collected in graph 
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